VmWare Server 1.0.4 on Ubuntu Server 7.04 (a.k.a Feisty Fawn)

2 days after my previous post about installing VmWare Server 1.0.3 from Canonical’s repository, VmWare released version 1.0.4.

I tried using its built-in install script on a vanilla Ubuntu Server 7.04 (a.k.a Feisty Fawn) and it worked flawlessly.

Aside from certain libraries which it needs to compile the vmmon and vmnet kernel modules (the installation script will tell you which ones are missing and you can get them from the repositories using apt-get), you’ll also need to install xinetd.

All in all, the installation script did all the job and it works fine without patching the vmmon code.

Keep up the good work VmWare Team!

Ubuntu Feisty Fawn (7.04), VmWare Server and Authentication problems

If you are going to install VmWare server (a great and free server virtualization product from VmWare) on Ubuntu Feisty Fawn (7.04) and you’ve followed this post showing how to do it using Canonical’s commercial repository, make sure to read this post at the Ubuntu Community Docs.

Basically, if you encounter authentication problems at the Server’s Console after installing the VmWare server and until this bug is fixed, you need to edit /etc/pam.d/vmware-authd to contain:

#%PAM-1.0
auth required pam_unix_auth.so shadow nullok
account required pam_unix_acct.so

Afterwards, restart the VmWare service and try to authenticate using the server’s console again.

I’m just being the Good SEO Samaritan and bumping this article’s SEO so everyone will see it first (instead of it being buried down somewhere and the search results) :-) .